PHP5 End of Life: 31 december 2018

Het gaat niet lang meer duren dat PHP5.6 -en daarmee de hele PHP versie 5 range- de “end of life” status krijgt. De datum waarop PHP5 de end of life status krijgt is op 31 december 2018. Dus aan het einde van dit jaar. Dit betekent dat PHP5 vanaf dan niet meer ondersteund wordt.

Dit is een belangrijk gegeven voor Magento webshops. De simpele reden is dat Magento -met name oudere versies van Magento- gebruik maakt van PHP5. Er zullen na 31 december 2018 geen security fixes meer worden gemaakt en aangeboden voor PHP5 door de PHP contributing members. Dit creëert dus een noodzaak voor Magento shops, om een te oude PHP versie te upgraden, dan wel om oude Magento shops (en daarmee de gebruikte PHP versie) te vervangen voor nieuwere versies.

De oudere versies van Magento 1, tot en met Magento 1.9.2 en lager, maken gebruik van PHP5. Als PHP5 niet meer wordt ondersteund, dan heeft dit weerslag op deze oudere Magento installaties. Want door de end of life status wordt PHP5 feitelijk ongeschikt voor gebruik: de security risico’s worden te groot. Er is nog wel wat oplapwerk mogelijk, maar dit zijn ook maar weer tijdelijke oplossingen.

Als Magento webshop, heb je PHP nodig om de webshop goed te draaien. Als PHP niet juist is geconfigureerd of de verkeerde versie heeft, dan is het risico dat de shop niet goed -of zelfs geheel niet meer functioneert- erg groot.

Magento 2 gebruikt PHP versie 7.  Ook Magento 1.9.3 en hoger kan werken met PHP7. Maar check wel of je de juiste versie hebt. Ook PHP7.0 en binnenkort ook PHP7.1 lopen richting end-of-life status. Houd dat ook in de gaten…

Dus onze tip: laat de PHP versie van je shop goed checken, om problemen te voorkomen.

WhatsApp Chat